Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

7350a - stand-alone - no glm

mrkeeny, muokattu 3 Vuodet sitten.

7350a - stand-alone - no glm

Youngling Viestejä: 2 Liittymispäivä: 14.12.2018 Viimeisimmät viestit

Hello, I purchased a 7350 sub to go with my 8030s without the glm kit.

The device powers on with a green light and audio is passed through to my 8030s, but no sound from sub.

Is there a way to control the sub volume without glm kit? 

I’m not sure whether the device is defective or whether it’s been programmed to start at zero volume.

Any help to troubleshoot will be much appreciated.

Regards, Martin 

mrkeeny, muokattu 3 Vuodet sitten.

RE: 7350a - stand-alone - no glm

Youngling Viestejä: 2 Liittymispäivä: 14.12.2018 Viimeisimmät viestit

Update: I purchased the GLM kit to see whether the system was stuck at low/no volume setting.

The software sees the sub and I have been able to update firmware, but still get no sound. The device responds to all power commands, but when I try and send a test signal all I hear is a click.  Any ideas for anything else I can try?  Looks like I bought a turkey!

jani-oksanen, muokattu 3 Vuodet sitten.

RE: 7350a - stand-alone - no glm

Jedi Master Viestejä: 449 Liittymispäivä: 30.3.2017 Viimeisimmät viestit

Hi Martin,

I'm sorry to hear about the troubles.  Could you please contact us through our Service Enquiry Form: https://www.genelec.com/service-enquiry-form

Please include information below:
 

1. Have you been able to calibrate the subwoofer?

2. If yes, include callibration setup by going to "Help|Export Setup to Desktop", and attaching it to the service enquiry form.

 

Best Regards,
Jani Oksanen
Customer Support Team