Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

8341 problem

Mix & Mouse, muokattu 2 Vuodet sitten.

8341 problem

Youngling Viestejä: 3 Liittymispäivä: 26.5.2020 Viimeisimmät viestit

Hi,
​​​​​​​It's the second time I send to my reseller a 8341 speaker. My problem is, I think, the loudspeaker put in security. i don't know why. I can see the green light when I put on the power but the speaker doesn't work.

​​​​​​​And today, it's the serie ^^, I got a beep and after 3, 4 beeps on my other speaker. In attachemnt you have a video. But it works after. Is it a warning ? I can't turn off the speaker.

My signal is analog and I don't have GLM.

​​​​​​​Am I alone with this ?

jani-oksanen, muokattu 2 Vuodet sitten.

RE: 8341 problem

Jedi Master Viestejä: 449 Liittymispäivä: 30.3.2017 Viimeisimmät viestit

Please contact Genelec support at support@genelec.com

Mix & Mouse, muokattu 2 Vuodet sitten.

RE: 8341 problem

Youngling Viestejä: 3 Liittymispäivä: 26.5.2020 Viimeisimmät viestit

I sent it. Thanks