Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support


8341 ISS Mode Not Working

mikeg, muokattu 2 Vuodet sitten.

8341 ISS Mode Not Working

Youngling Viestejä: 2 Liittymispäivä: 18.7.2020 Viimeisimmät viestit

Hi everyone. I have recently received my 8341s (pair). I have enabled the the rear dip for ISS and disconnected the GLM box ( I left the cat5 cable plugged into the speaker as its awkward to get to). ISSS does not seem to enable. I am assuming the LEDs will go out? What am I doing wrong here? Is there an additional setting in software? (GLM and Speakers on latest firmwares as of today)