Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

Analog signal mutes when I switch digital switches to on

alanshed, muokattu 4 Vuodet sitten.

Analog signal mutes when I switch digital switches to on

Youngling Viestejä: 1 Liittymispäivä: 11.4.2017 Viimeisimmät viestit
Hi All. I've had my pair of 8340A speakers with the GLM module for a week now and I keep going from loving them to pulling my hair out.

This wasn't happening at first I'm sure but today, flicking any of the digital A B switches up on the back seems to mute the analog input. At the beggining of the week though I'm sure I had Analog and Digital connected and when there was no digital signal it would just play the Analog.

I've unplugged the GLM adaptor and reset both speakers to factory defaults so it's as if they are out of the box, never plugged into the GLM but still the switches mute the Analog signal, even when there is nothing plugged into the digital sockets.

Does this mean that once I've set the digital switches for my preferred stereo digital configuration, I need to flick them back off every time I want to plug in an analog signal?

'Would really appreciate some help on this.

'Alan
mazhar, muokattu 4 Vuodet sitten.

Re: Analog signal mutes when I switch digital switches to on

Youngling Viestejä: 20 Liittymispäivä: 11.2.2014 Viimeisimmät viestit
Hi All. I've had my pair of 8340A speakers with the GLM module for a week now and I keep going from loving them to pulling my hair out.

This wasn't happening at first I'm sure but today, flicking any of the digital A B switches up on the back seems to mute the analog input. At the beggining of the week though I'm sure I had Analog and Digital connected and when there was no digital signal it would just play the Analog.

I've unplugged the GLM adaptor and reset both speakers to factory defaults so it's as if they are out of the box, never plugged into the GLM but still the switches mute the Analog signal, even when there is nothing plugged into the digital sockets.

Does this mean that once I've set the digital switches for my preferred stereo digital configuration, I need to flick them back off every time I want to plug in an analog signal?

'Would really appreciate some help on this.

'Alan


I suggest you just keep the stored switch on the back panel enabled. You can then calibrate for AES (Digital A/B) and analog signals from the GLM software itself. You will then be able to play both analog and digital audio whenever you switch your groups, within the same file.

Hope this works!
ensoniq, muokattu 4 Vuodet sitten.

Re: Analog signal mutes when I switch digital switches to on

Padawan Viestejä: 47 Liittymispäivä: 30.5.2015 Viimeisimmät viestit
Alan I was also wondering 2 years ago with my first 8260 . You are correct. You can not expect the Gens to automatically detect if analog or digital soundsource is feeding the monitors. BAsed on the prinicple the GENs needs GLM Monitor storrage of Digital or Analog group setting . Then you can switch digital and analog but only by making use of the GLM software .