Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

6010 doesn't turn on

okovoko, muokattu 7 Vuodet sitten.

6010 doesn't turn on

Youngling Viestejä: 2 Liittymispäivä: 20.10.2014 Viimeisimmät viestit
One 6010 will not switch on, have changed fuse, tried other leads and no luck.

Is there anything else to try before having to send in for a service?

some way to reset the internal power-save trip circuit perhaps? [I really wish that circuit wasn't there, I don't trust it and it clicks all the time....speaker on or off is fine with me....anyway]
1038, muokattu 7 Vuodet sitten.

Re: 6010 doesn't turn on

Jedi Master Viestejä: 340 Liittymispäivä: 6.4.2009 Viimeisimmät viestit
How did you change the fuse, and which one did you change??
okovoko, muokattu 7 Vuodet sitten.

Re: 6010 doesn't turn on

Youngling Viestejä: 2 Liittymispäivä: 20.10.2014 Viimeisimmät viestit
Just the one in the plug, I'm not going to open the main housing as its still under warranty. Not even a year old. Very disappointing. I have 6020s and 6030s and this is the first time I've hit trouble
1038, muokattu 7 Vuodet sitten.

Re: 6010 doesn't turn on

Jedi Master Viestejä: 340 Liittymispäivä: 6.4.2009 Viimeisimmät viestit
It'll just be the mains power fuse, unfortunately the fuse is soldered on the amp circuit board which requires the speaker to be opened... Contact the company you purchased them from to organise warranty repair...

It's only a fuse, don't stress, These are as well built as your 8020's and 8030's....