Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

F One Subwoofer stopped working

skipperz90, muokattu 8 Vuodet sitten.

F One Subwoofer stopped working

Youngling Viestejä: 3 Liittymispäivä: 23.4.2014 Viimeisimmät viestit
Hello,

My 1-year old F One subwoofer suddenly stopped playing bass sounds. The subwoofer hasn't been damaged in any way nor have I changed the cables to different in/outputs. My brother tried to hook up his Android smart phone to the subwoofer and it turned out that he had to boost the bass from the software A LOT to get a decent bass from the subwoofer. I have been using it mainly with my PC and sound card (no changes also to those). I think it should be sent to warranty repair (there should be a year left).

What do you think?
ilkka-rissanen, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Hi,

Can you check that the subwoofer's volume is set to maximum? Please use the supplied RF remote control to check this.

Are you using only the subwoofer or do you have some Genelec speakers connected to it too (signals routed through the subwoofer)? If yes, are they still playing normally?
villetou, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Youngling Viestejä: 3 Liittymispäivä: 27.4.2014 Viimeisimmät viestit
My F One is also working really poorly now. Most of the time it doesn't seem to recognize the signal from the computer and doesn't turn the speakers on (itself and 2 x G Twos). Sometimes it works, but it might turn off in the middle of playing music. I've tried different amp levels from computer but it doesn't seem to do anything. Any tips? Time to send F1 for fixing? :?
villetou, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Youngling Viestejä: 3 Liittymispäivä: 27.4.2014 Viimeisimmät viestit
I put the subwoofer aside and connected my G2's straight to computer and they also didn't play any audio suddendly. I unhooked everything for a couple of hours and put the whole system on a different power extension cable and just played some songs from my tablet and then tv. Now they seem to work fine, hopefully they aren't damaged!

Can a spike in power and/or audio input mess up the power saving functionality and what is the chance of damage to the speaker system? The speakers shared the same extension cord as the computer, and the computer soundcard is in internal type with RCA outputs. What do you think might be a cause of this? I'm really concerned about this...

Of course there's a lot of factors in here, but any ideas guys?
ilkka-rissanen, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Hi villetou,

That is a really strange problem. It would be interesting to hear if you can reproduce the behaviour by connecting them back to the same extension cord? Won't the speakers turn on then? I wouldn't be concerned about damaging them.

Could you also let me know the serial numbers for the speakers and the subwoofer?
villetou, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Youngling Viestejä: 3 Liittymispäivä: 27.4.2014 Viimeisimmät viestit
I'll try today again with the tablet and tv and make sure everything is working with those. Those are using the 3,5mm jack as output so there's a bit of difference with the setup. I have a feeling the extension cables are unrelevant in this and the problem is the computer soundcard (audiophile 2496) and maybe the power supply. I'll do some more testing and get back to you. 8-) Thanks

PS. I'll PM the serial numbers in the evening!
skipperz90, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Youngling Viestejä: 3 Liittymispäivä: 23.4.2014 Viimeisimmät viestit
Hey,

sorry for the late reply. I also have the Genelec G one's hooked up with the F One. The problem seems to be that F One is working really poorly. Even if the F One volume is set to max. As I mentioned earlier, my brother hooked up his android phone to F1 and set the bass levels to max from the phone, which resulted the F1 working fine. But with my PC, I'm having hard time to play decent bass.
ilkka-rissanen, muokattu 8 Vuodet sitten.

Re: F One Subwoofer stopped working

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Hi,

It would seem that there is something wrong with your subwoofer and it needs professional service. Please contact your local distributor for a service request.

http://www.genelec.com/shop/distributors-network/