Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

Genelec 8050A

krizz, muokattu 11 Vuodet sitten.

Genelec 8050A

Youngling Viestejä: 2 Liittymispäivä: 20.4.2011 Viimeisimmät viestit
hi,
I have a pair of genelec 8050a for 5 year now.
They sound really great !!!
For the second time the low amplifier has "blown up" and need to be fixed, first the left speaker (after 2 year) now the right speaker (after 5 year)... :cry: :cry: :cry:

-Is this normal or is it something else?
-Could it be a problem with heat fluctuations? (room temperature is various)
-Or is this an isolated case?
Can someone explain this problem with my speakers?
Kind regards Krizz
wavm, muokattu 10 Vuodet sitten.

Re: Genelec 8050A

Youngling Viestejä: 1 Liittymispäivä: 19.7.2011 Viimeisimmät viestit
I too experiencing the same issue, again my 8050's are 5 years old.
My right then left went and had the amp card replaced in both, today my right blew again
and is on it's way back for service. Not what you buy Genelec speakers for!
Why is this happening and all the expenses / loss of work that goes with it?
mrwes, muokattu 10 Vuodet sitten.

Re: Genelec 8050A

Youngling Viestejä: 1 Liittymispäivä: 8.2.2012 Viimeisimmät viestit
Alright..

Soooo.. Im definitely having the same issue.
Only BOTH of my woofers are not working. I had one of the amplifier module thingys replaced just a few months ago. and now both are blown, or just not working, and after I'd recieved them, I plugged them in once to test, but put them away bc our facility had already broken in a whole nother Adams setup.

Whats up with that.

And why can I not purchase the parts myself and have a local audio repair shop do the work for me.
Granted these monitors are ALREADY at such a high price point, the cost of shipping them to the ONLY genelec repair facility in the USA, followed by parts and labor is quite ridiculous.

Paying something like $300/monitor repair??
Is there anywhere that I may purchase this piece and rectify this seemingly common issue. AND also learn of ways to prevent this costly mishap of a failure from happening to me again.

Thanks
krizz, muokattu 7 Vuodet sitten.

Re: Genelec 8050A

Youngling Viestejä: 2 Liittymispäivä: 20.4.2011 Viimeisimmät viestit
---
bauerlanford, muokattu 7 Vuodet sitten.

Re: Genelec 8050A

Youngling Viestejä: 3 Liittymispäivä: 3.9.2013 Viimeisimmät viestit
Same thing happened to me for the 3rd time today. This REALLY SUCKS.

Please Genelec, let us know what's going, why is this happening to our speakers?