Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

1091A Sub problem

andy-d, muokattu 11 Vuodet sitten.

1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
Hi,

I have a pair of Genelec 1029A monitors with a Genelec 1091A sub.

I've just switched them all on to work on a mix that I have been working on for some time and the sub is very weak in power. The output is far lower than usual.

I've eliminated the problem being the mix (all the levels are where they should be) and it isn't the cables either. I've tried on some dub tunes too and the sub just isn't performing...

Any ideas?

Thanks
Andy
ilkka-rissanen, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Hi,

So you changed something in your setup and then the subwoofer became weak? What did you change and can you change it back?
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
Hi,

Thanks for your prompt response.

No, I haven't changed anything. All is exactly the same.

But the sub is just weak in power, there is only a small amount of sub-bass output. A lot less than usual.

Andy
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
I've just been listening to the sub on it's own without any attenuation and the it has making a sort of 'farty' sound. As if maybe the speaker has blown? Or could it be something else?

Are there any checks I can do?

Andy
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
But I can't imagine it is blown as I rarely use the sub and the system is never run at a loud volume?
ilkka-rissanen, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
It is difficult for me diagnose the exact fault from here, but it looks like your subwoofers needs professional service. Please contact your local distributor for further information: http://www.genelec.com/sales-network/
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
okay, thanks
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
Hi Ilkka,

I have since found out, after a few tests, that the driver has definitely not blown and the 'farty' sound was actually down to one of the screws that fixes the amp on top of the sub box coming loose and the amp was vibrating.

However, I am still getting a low output.

So, after eliminating the driver as being the problem... do you have any ideas of what may be going wrong within the amp itself? Does anything immediately ring any bells as to why there would be a low output?

I have eliminated the cables as being the problem too.

Best,
Andy
andy-d, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Youngling Viestejä: 7 Liittymispäivä: 8.11.2010 Viimeisimmät viestit
I've just read that a blown capacitor or resistor may cause a problem like this??

Does that sound right?
ilkka-rissanen, muokattu 11 Vuodet sitten.

Re: 1091A Sub problem

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Hi,

There are hundreds of electrical components inside the amplifier, and since many of those directly affect the output of the device, it is impossible for me to guess the possible failure. The amplifier needs to opened up by a qualified Genelec technician.