Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

did I damage my 8250's

tesla, muokattu 12 Vuodet sitten.

did I damage my 8250's

Youngling Viestejä: 16 Liittymispäivä: 18.11.2009 Viimeisimmät viestit
I was moving some bass traps from behind the speakers when the trap fell and landed on the cables. This caused the 8250's light to blink from orange to red to green and then a loud feedback noise came from the speaker.

I had to unplug the speakers to get the noise to stop...

I then turned them off and then on again but the blinking continued...

After waiting about 10 minutes with the speakers off I turned them on again and everything seemed normal, the speakers lights stayed green and audio was reproduced as usual.

Can I expect problems in the future?

Thanks.
spider, muokattu 12 Vuodet sitten.

Re: did I damage my 8250's

Youngling Viestejä: 11 Liittymispäivä: 25.1.2010 Viimeisimmät viestit
Yeah, they're screwed.
Send them to me; I'll dispose them for you. :lol: