Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

Genelec 7070A stopped making sound

pj, muokattu 4 Vuodet sitten.

Genelec 7070A stopped making sound

Youngling Viestejä: 1 Liittymispäivä: 25.6.2017 Viimeisimmät viestit

Hello!

Yesterday when playing some music, my ~10 years old Genelec 7070A subwoofer suddenly made a "pop sound", the sound went a little bit distorted I think, but in just a second I turned down the volume.

When I turned up the volume again, I got no output either from the sub or my main speakers. However, the power LED green light goes from green to red.

Do you think my sub is dead forever, or is there any fuse somewhere that made this?

ilkka-rissanen, muokattu 4 Vuodet sitten.

RE: Genelec 7070A stopped making sound

Yoda Viestejä: 2564 Liittymispäivä: 23.3.2009 Viimeisimmät viestit
Please contact our service department.