Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Keskusteluryhmät

Speaker Noise when power cable is attached

bobbycanasta, muokattu 4 Vuodet sitten.

Speaker Noise when power cable is attached

Youngling Viestejä: 1 Liittymispäivä: 12.8.2017 Viimeisimmät viestit

Hi!

I just bought a pair of used 8020a. One of the speakers has a terribly loud ground noise when I plug in the power cable. Even if the speaker is in off position. No signal cable is attached. 

Do you know what could be wrong and is it an easy fix? 

Attached is a video of the problem.

Thanks!


Björn

jani-oksanen, muokattu 4 Vuodet sitten.

RE: Speaker Noise when power cable is attached

Jedi Master Viestejä: 449 Liittymispäivä: 30.3.2017 Viimeisimmät viestit

Hi Björn,

I have forwarded this problem to our service center in Sweden, and they should be in touch with you soon. If you don't receive reply from them in few days, please contact us again at service@genelec.com

Best Regards,
Jani Oksanen
Factory Service Team