Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

GLM Adapter offline after Firmware update

Jensen, modified 2 Years ago.

GLM Adapter offline after Firmware update

Youngling Posts: 1 Join Date: 4/13/20 Recent Posts

I have the following setup running: 8330A SAM,7350A SAM & GLM Kit & MacBookPro fresh OSX 10.13.6 (17G66). The setup was very easy. Measuring and calibrating also worked great. Sound awesome. Everything runs perfect until I started accidentally an second firmware update of the GLM adapter. After that my GLM Box no longer connects via USB. Status LED on the box is inactive.

I installed the current GLM software on another Mac but unfortunately the same problem.

Any Ideas how to solve this issue?