Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

Genelec 8330 A with yamaha wxc-50

alvar111, modified 2 Years ago.

Genelec 8330 A with yamaha wxc-50

Youngling Posts: 4 Join Date: 6/1/20 Recent Posts

Hey!

 

I am finding trouble connecting my streamer (yamaha wxc-50) and my speakers/monitors (genelec 8330 am bundle). I have wired them correctly but somehow the sound from my phone does not end up in the speaker through the streamer. Or then it does but something is up with the volume of the speaker.

 

+ can someone give me ”basic” levels for glm group settings startup level volume and standalone max volume. Is 0 ja -15 good?  + does anyone know why arent my speakers playing the music I am playing through my streamer?

 

any help appreciated

 

Alvar

lewismiles, modified 2 Years ago.

RE: Genelec 8330 A with yamaha wxc-50

Youngling Posts: 0 Join Date: 11/3/20 Recent Posts
alvar111:

Hey!

 

I am finding trouble connecting my streamer (yamaha wxc-50) and my speakers/monitors (genelec 8330 am bundle). I have wired them correctly but somehow the sound from my phone does not end up in the speaker through the streamer. Or then it does but something is up with the volume of the speaker.

 

+ can someone give me ”basic” levels for glm group settings startup level volume and standalone max volume. Is 0 ja -15 good?  + does anyone know why arent my speakers playing the music I am playing through my streamer?

 

any help appreciated

VidMate

Alvar

 

 

issue got solved