Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

8331a clipping red light

drock, modified 2 Years ago.

8331a clipping red light

Youngling Posts: 16 Join Date: 2/9/14 Recent Posts

Hello everyone, I finally bought a beautiful pair of 8331a’s and I’m noticing the red clip light go on when I have the volume up, I am not blasting the volume but I am getting the red clip light linking ?

i also have the speakers as loud as they can go on +6.

is this normal ?

it is not distorting but the red light is distracting.

drock, modified 2 Years ago.

RE: 8331a clipping red light

Youngling Posts: 16 Join Date: 2/9/14 Recent Posts

I think I may have figured it out, my mixes all have too much low end, I put on a Steely Dan song and turned up the volume pretty loud and no red clip light  :-) wow this speaker is really going to help me and my mixing !! And I still haven’t set up the GLM kit :-) I had the M040 monitors before this and although they served for many years... I am now in the big league lol I am a tru Genelec fan all the way for life.