Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

no high frequencies and strange sound --> Broken Speaker?

suplifth, modified 4 Years ago.

no high frequencies and strange sound --> Broken Speaker?

Youngling Posts: 5 Join Date: 2/6/17 Recent Posts
Hi

I bought two new monitors 8010APM and now I want to test it.
Unfortunately one monitors frequencies above 11kHz sounds muted.
It sounds like cable will not fully fit (maybe some of you know this sound)...

Cable is ok, I tried with the other one. Audio interface Output I also tried everything.
So is there something I forgot to test or can it only be a broken "tweeter"?
suplifth, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Youngling Posts: 5 Join Date: 2/6/17 Recent Posts
The same problem as here:

viewtopic.php?f=4&t=1925

I also use the Focusrite Scarlett 6i6.
I will check first if I also gets problem when plug to another Audio out.
ilkka-rissanen, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Hi,

Can you test the speaker with some other source device, for example just connect your mobile phone to it with an adaptor cable. If the tweeter would be broken, everything above ~3 kHz would be muted as that is the crossover frequency.
suplifth, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Youngling Posts: 5 Join Date: 2/6/17 Recent Posts
Hi
Thank you for answering.
3kHz?

Then I will be sure, that the problem will be another, cause I still can hear frequencies when Signal is lowcutted about 10k (but not clearly).

Could it be some Problem with the recessed XLR connector?

I will test with another source device.
suplifth, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Youngling Posts: 5 Join Date: 2/6/17 Recent Posts
I just tested and both Monitors sounds same when i check with other source device.
ilkka-rissanen, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Ok, so that rules out any defect in the speakers themselves. Please check your source and especially audio interface settings.
suplifth, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Youngling Posts: 5 Join Date: 2/6/17 Recent Posts
ok sorry I have to correct me. had yesterday only short time. Today I tested with cellphone and it seems that one speaker sounds not same as the other. but it sounds like mono. cable is ok.
ilkka-rissanen, modified 4 Years ago.

Re: no high frequencies and strange sound --> Broken Speake

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Can you send me a recording of how the two monitors sound? You can use your mobile phone to record the video.

Also, can you let me know the monitor's serial numbers and place of purchase. Where are you located? Have you already contacted the dealer?