Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

8351A sounds strange when switching on

nachjos, modified 5 Years ago.

8351A sounds strange when switching on

Padawan Posts: 41 Join Date: 10/21/16 Recent Posts
One of my 8351A makes bad 'krrrrrrrrch' sound when switching on. It sounds like a loose contact on the switch. The other speaker sounds totally different and just make a silent, short 'plop' when switching on. Soundwise everything seems to be OK. Is there something I have to worry about?
ilkka-rissanen, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Hi,

I would not worry about it too much. Slight differences in power up or down noise is normal and doesn't mean there would be anything wrong or broken with the product. Of course you should monitor if it gets progressively worse or develops other symptoms. In that case please be in contact again.
nachjos, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Padawan Posts: 41 Join Date: 10/21/16 Recent Posts
Hi Ilkka

Glad to get the first reply from you! I am new to this forum, but watching it since a few weeks.

The 8351A is a great product with such excellent quality, that I would like to know how this significant differences between two speakers could exist. Do you have any idea?

Otherwise I will go with your advise and monitor this behaviour without worry... :-)
ilkka-rissanen, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Would it be possible to record a short video (mobile phone quality is fine) of both units powered up one at a time and send it to support (at) genelec.com so that we could investigate it better? Thank you!
nachjos, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Padawan Posts: 41 Join Date: 10/21/16 Recent Posts
I tried to uploaded two sound file as a example. All file types I tried (M4A, MP3) are not supported for Upload. Sorry...
ilkka-rissanen, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
I tried to uploaded two sound file as a example. All file types I tried (M4A, MP3) are not supported for Upload. Sorry...

Please email them to support (at) genelec.com

Thanks!
nachjos, modified 5 Years ago.

Re: 8351A sounds strange when switching on

Padawan Posts: 41 Join Date: 10/21/16 Recent Posts
@Illka
I send mail to genelec support.