Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

Hissing 8351

lukester, modified 5 Years ago.

Hissing 8351

Jedi Master Posts: 296 Join Date: 4/22/10 Recent Posts
crap in a jar,

one of my 8351 test units startet emitting something alike 50Hz hum:
https://www.wetransfer.com/downloads/ec ... 931/60dddb

probably a coincident, but the issue started after wakeup from stand-by.
problem persists without any signal cables connected.
ilkka-rissanen, modified 5 Years ago.

Re: Hissing 8351

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Sounds like a defected unit, please contact your dealer and request service.