Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

Will GLM 2 work with Mac OS 10.8.5?

studio-dweller, modified 6 Years ago.

Will GLM 2 work with Mac OS 10.8.5?

Youngling Posts: 1 Join Date: 5/16/09 Recent Posts
I'm currently using GLM 1.5 on a 2008 Mac Pro and OS 10.8.5. Since the upgrade to GLM 2 offer expires at the end of the year I'm considering upgrading, but I need to know if GLM 2 will work on my system.

Thank you.
digipete, modified 6 Years ago.

GLM Trade-in program extended to June 2016

Padawan Posts: 99 Join Date: 6/18/11 Recent Posts
The duration of the GLM Trade-in program has been extended to be ending on the 30th of June 2016.

See more in the tread: GLM 2.0 Trade-in Program


No reason to panic ;-)
ilkka-rissanen, modified 6 Years ago.

Re: Will GLM 2 work with Mac OS 10.8.5?

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
We quarantee compatability with 10.9 and newer but 10.8 should work fine too.