Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

GLM 2.0 adapter stopped working *fixed*

jantex, modified 7 Years ago.

GLM 2.0 adapter stopped working *fixed*

Padawan Posts: 36 Join Date: 3/11/15 Recent Posts
Hi, I have been successfully using GLM 2.0 in combination with 8351 speakers since beta version on OSX released on 30th April till today. I have also updated to the 2.04 version and it worked until today. Today I simply cannot get adapter to work anymore. I tried connecting it to other USB ports of my Mac, I reseted PRAM, SMC, disconnected it, reinstalled GLM software. But its status is always OFFLINE and is coloured red in GLM software picture.

The orange light still indicates when it is connected to USB port, but it simply doesn't work and remains OFFLINE all the time. I have had applied room correction to my speakers and I simply cannot work without it anymore. What else could I try. Is it possible that it has gone dead?

When I connect it to USB now, orange led on speakers start blinking for a short time and then it goes back to green. But adapter doesn't get ONLINE.

Best regards, Tine
jantex, modified 7 Years ago.

Re: GLM 2.0 adapter stopped working

Padawan Posts: 36 Join Date: 3/11/15 Recent Posts
Problem solved. USB ports experienced sudden problem. Once solved, GLM adapter started to behave normally.