Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

1091A F1 fuse blowing...

crq23, modified 7 Years ago.

1091A F1 fuse blowing...

Youngling Posts: 1 Join Date: 5/18/15 Recent Posts
Hello,

my 1091A sub has its F1 fuse (250v 1A T) that keeps blowing at power on.
do you have any hints of what could cause this failure ?

best regards

Frederic
ilkka-rissanen, modified 7 Years ago.

Re: 1091A F1 fuse blowing...

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Hello Frederic,

I would advice you to contact your local distributor and their service centre first. You can search for their contact information here:


http://www.genelec.com/shop/distributors-network/