Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

8240a - 'pop' sounds when switching on

kinglourinho, modified 8 Years ago.

8240a - 'pop' sounds when switching on

Youngling Posts: 9 Join Date: 8/16/13 Recent Posts
Dear all,

Another issue I've noticed on my 8240a's:

When switching them on the speakers make two clear 'pop' sounds. The first one sounds like it's coming from the tweeter and a second later another one coming from the woofer. This happens in both units.

Is this something normal? :roll:

All the best
ilkka-rissanen, modified 8 Years ago.

Re: 8240a - 'pop' sounds when switching on

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Hi,

Yes it's perfectly normal to have faint 'pop' sounds when the speaker is turned on.
udayan, modified 8 Years ago.

Re: 8240a - 'pop' sounds when switching on

Padawan Posts: 38 Join Date: 6/6/13 Recent Posts
Hello,

I have the same kind of pop in the woofer of one of my 8260 ! But surprisingly the other is dead silent when switched on ?

Cheers,



Udayan