Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

PROBLEM: giant hum coming from 7060A

jackthinks, modified 10 Years ago.

PROBLEM: giant hum coming from 7060A

Youngling Posts: 3 Join Date: 8/14/12 Recent Posts
Hi All, I'm here hoping someone from Genelec will take notice of this post (I've already emailed them and received no reply).

I have a pair of 1030As and the corresponding 7060A subwoofer. Weeks ago a very loud hum (60hz maybe?) came screaming out of the sub and into the 2 monitors. There was no audio running to any of the monitors, but the power on each of them was on. After cutting off power to the 1030As I could still hear the tone coming from the sub. I cut the power to the sub and the tone stopped.

I re-routed my audio outs to the (2) 1030As (bypassing the sub) and all is okay. I tried giving power to the sub again and the tone still shoots out from it, so I am stuck now with I guess a broken sub? Has anyone else experienced this?
Does Genelec have any experience with this problem? I am thinking it might be a ground issue but I'm not sure.

The sub is very heavy and I'd like some info so I can consider my options....repairing it would likely require hiring someone to help me lug it to a repair shop and back via taxi. I would also like a recommendation on what repair shop in New York City would be best. Or maybe purchasing a new sub would be more economical? Info from Genelec would be appreciated here. Thank you for any info you can provide. Cheers and happy mixing.

Jack
ilkka-rissanen, modified 10 Years ago.

Re: PROBLEM: giant hum coming from 7060A

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts
Hi,

To which email address and when did you try to contact Genelec?

Since you are located in the US, the correct contact information is:

GENELEC Inc. - 7 Tech Circle - Natick - MA 01760 - USA - Tel +1 508 652 0900 - Fax +1 508 652 0909 - Email genelec.usa@genelec.com
jackthinks, modified 10 Years ago.

Re: PROBLEM: giant hum coming from 7060A

Youngling Posts: 3 Join Date: 8/14/12 Recent Posts
I used the form on your website. I will call the MA number. In the mean time if you have any advice for me, feel free to post it or email me at nycthinker@earthlink.net.
Thanks.
jackthinks, modified 10 Years ago.

Re: PROBLEM: giant hum coming from 7060A

Youngling Posts: 3 Join Date: 8/14/12 Recent Posts
Just spoke to someone in the MA location and I have a plan in place. I'll post results here if anyone is interested.
dj-mr-alex, modified 4 Years ago.

RE: PROBLEM: giant hum coming from 7060A

Youngling Posts: 8 Join Date: 4/6/17 Recent Posts

Did you get it resolved having the same problrm here?

 

bgronas, modified 3 Years ago.

RE: PROBLEM: giant hum coming from 7060A

Youngling Posts: 0 Join Date: 8/8/19 Recent Posts

PLEASE, did anyone fix this? Can you put me in the right direction?

 

jani-oksanen, modified 3 Years ago.

RE: PROBLEM: giant hum coming from 7060A

Jedi Master Posts: 449 Join Date: 3/30/17 Recent Posts

If you have any problem with Genelec product, please contact our service directly for help.

https://www.genelec.com/customer-service 

Best Regards,
Jani Oksanen
Customer Support Team