Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

Orange light and no sounds from 8250 and 7270

cash, modified 5 Years ago.

Orange light and no sounds from 8250 and 7270

Youngling Posts: 1 Join Date: 5/28/17 Recent Posts

I recently had to wipe my computer and start from scratch. During this process I found it extremely hard to get the GLM software for my set up (8250s and a 7270). Trying to get GLM v1 off of the Genelec site was amusing. I kept getting redirected to the GLM2.0 which stated it wont work with my system. Great, thanks! Super helpful.

Luckily I was able to dig through some old boxes and I found the physical GLM CD. 

HERE IS MY ISSUE: I have correctly set up the GLM software and calibrated the speakers using the wizard. However, now as soon as i select my set up from the options in the software, my monitors wont produce sound. The lights stay orange and don't turn to green. However, during the set up, The speakers all played their test tones. 

If I use analog cables, the monitors work fine, but this forces me to bypass my 7270. 

Any idea why my monitors lights won't change off orange to green? Is it because the GLM is from the CD and pretty dated? Is it something Genelec did? Is my sub now a giant brick? Can I even get the most recent version of GLM v1?

The monitors and sub were working perfectly before i had to wipe my harddrive and start from scratch and again, they all played test tones during calibration and the monitors work with analog cables.

Any help is super appreciated.

 

 

ilkka-rissanen, modified 5 Years ago.

RE: Orange light and no sounds from 8250 and 7270

Yoda Posts: 2564 Join Date: 3/23/09 Recent Posts

Hi,

GLM v1.5 and GLM.SE v1.3.1 are now available here, sorry for the trouble!

https://www.genelec.com/support-technology/previous-models/glm-10-software

https://www.genelec.com/support-technology/previous-models/glm-se-software

 

Have you managed to sort out the issues already or is the system still behaving strange?