Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

4030b with 5040a

roksu, modified 5 Years ago.

4030b with 5040a

Youngling Posts: 3 Join Date: 1/17/11 Recent Posts

Hey there

I just recently manage to purchase 2 4030b speakers which I thought I could replace the 6030a:s I have connected to a 5040a.

But when I connect them to the subwoofer, they start humming... they actually hum as soon as I have the cable connected to them even if the cable is not attached anywhere. If I remove the cable from the speaker, the hum stops. The cables have the phoenix connctor in one end and rca connectors in the other end. It does not help either if I remove the inputs from the subwoofer. The really odd part is if I connect a 3.5mm to RCA female converter to the cables and plug it into my iPhone, the hum stops and the speakers work beautifully. The hum continues if I remove the 3.5mm plug from the iphone....

What can cause this? Can the 4030b:s be connected to a 5040a?

 

roksu, modified 4 Years ago.

RE: 4030b with 5040a

Youngling Posts: 3 Join Date: 1/17/11 Recent Posts
Found the answer myself. Connected a jumper cable between minus and gnd and the problem went away. The speakers sound awesome!