Genelec Community Forum has been archived

Thank you for all the years of Community discussions and activity!

The time has come for us to retire the community forums, but we will keep everything available for reading. There is a lot of valuable content written over the years, and you'll be able to access all of that. However, no new posts can be written, or old posts modified.

If you have questions, we recommend you use the Support function on the bottom right corner to contact our Customer Support directly.

Alternatively, if you wish to engage in a community discussion with other people, there are many active forums available. There is also an active, fan managed GENELEC COMMUNITY in Facebook, and many Genelec employees are active in the discussions there.

We are sorry for any possible inconvenience this may cause you, but we hope to hear from you through the other channels mentioned above.

Genelec Support

Message Boards

GLM 2 Won't run on latest Mac OS

ohthepain, modified 6 Years ago.

GLM 2 Won't run on latest Mac OS

Youngling Posts: 3 Join Date: 2/28/17 Recent Posts

I updated my Mac OS to 10.13.1 and now the latest GLM2 software doesn't work. The menus disappear as soon as they open. I.e., when you tap on a menu name, the menu just flashes for a second.

This is on my mid-2014 Macbook Pro.

I tried holding the trackpad down, tapping the menus, etc. I also tried installing the latest version of the software, and restarting, but that that did not fix the problem.


laavu, modified 6 Years ago.

RE: GLM 2 Won't run on latest Mac OS

Youngling Posts: 10 Join Date: 3/2/16 Recent Posts
This is indeed an irritating bug and I hope this will be fixed soon. Basically it renders GLM 2 useless for people who happened to update their Macs to the latest macOS.